It is currently Sat 02. Jul 2022 6:49:55

All times are UTC + 1 hour





Post new topic Reply to topic  [ 126 posts ]  Go to page Previous  1 ... 8, 9, 10, 11, 12, 13  Next
  Print view Previous topic | Next topic 
Author Message
PostPosted: Wed 12. Jan 2022 8:28:31 
Offline
User avatar

Joined: Tue 10. Mar 2020 14:36:22
Posts: 272
Hello Matthias,

the most important question is: did you ever lose control of the model? even a short signal loss message (in the log) must not be a problem for let's say i.e. 0.3-0.5" if the model is still under control - this is the challenge.

telemetry showing some errors especially in Spektrum Min/Max screen is most probably not a problem of Spirit but between RX & TX and has already been a problem when i was still flying Spektrum (4651T and DX9/iX12). you are cutting power in the middle of packet transmission and this leads most probably to broken packets - if bad packets are not filtered correctly on TX side, this could be the result. i've seen many of them showing strange Min/Max values esp. on iX12... just like yours.

the same for frame losses when you connect/disconnect 1st RX. the 2nd RX does not know about the frame losses of the 1st RX. so in the moment you disconnect the 1st RX the 2nd RX will take over control and send "his" values for signal strength, fades and frame losses along with the telemetry values given by Spirit. the same happens when you re-connect the 1st RX. again, the mission is to have control of the model - and here the Spirit solution is absolutely great. to avoid those telemetry problems when disconnecting a RX to simulate signal problems and/or RX failure, you'll have to use a full size Spektrum RX with a sat attached to it - as recommended by Spirit.

_________________
cheers
Michael


Top
 Profile  
 
PostPosted: Wed 12. Jan 2022 10:40:50 
Offline

Joined: Wed 21. Dec 2016 15:13:38
Posts: 199
Location: Germany
Hi Michael,
controlling after disconnecting a satellite has always worked - the only problem is that after connecting the disconnected satellite, the telemetry spins, sometimes the values ​​are completely gone, then some utopian values ​​are there again -
If only one satellite is plugged in again, the values ​​are updated again, regardless of which satellite is being operated (4651T or 9747) whereby the frame losses are of course set to "0" again -

If one of the two satellites has been removed and plugged in again, the display on the remote control no longer makes sense and changes constantly and is therefore unfortunately unusable in my opinion at the moment -

I have never had arbitrary values ​​with just one 4651T satellite! The question must be allowed whether the telemetry makes sense at the moment - the control works, but there is a problem with the telemetry at the moment - maybe the firmware has to be sharpened a bit -

Many greetings
Matthias


Top
 Profile  
 
PostPosted: Wed 12. Jan 2022 10:46:23 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 11115
Hi,

if the receivers are too close each other or your radio is too close, it will have very bad signal. Then radio can process data incorrectly. In this matter there is nothing more that the Spirit unit can do unfortunately.
I recommend to try with only one satellite. Regardless of where you plug it in, it should just work and display correct values immediately.

As a side note, we never saw any strange value on Spektrum. All data are verified by CRC so only valid frames should be displayed.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Wed 12. Jan 2022 10:57:48 
Offline

Joined: Wed 21. Dec 2016 15:13:38
Posts: 199
Location: Germany
Hi Tomas,
If only one Receiver is connected it works perfect as said in my last post -

Maybe my TX is to near to the satellites because of direct sight in the TX -
Then it should work also for the SpiritII (FW 3.3.4 (11.01.22)) in your opinion ?

Best Regards
Matthias


Top
 Profile  
 
PostPosted: Sun 16. Jan 2022 21:53:52 
Offline

Joined: Sun 28. Nov 2021 19:48:59
Posts: 35
So, I got to test the new firmware in flight yesterday.

As per my bench testing, telemetry is working and I assume the 9747 sat was properly connected and ready to take control if needed. Sadly, I had a total loss of control when the model was ~30m altitude and ~120m distant.
The model went to failsafe and fell to the ground. It's worth noting that I had auto-rescue enabled at the time, and as the model fell through the hard deck, it levelled itself before it hit the ground. No doubt saving a lot of damage.

I don't think this is an issue with Spirit, as about one hour before, my 450 heli (BeastX FBL) also lost signal and crashed. Either there is some interference with Spektrum radios there, or my DX9 is faulty.

Also worth noting that I couldn't download Spirit logs, since it said it was corrupted. I've had that a couple of times now...


Last edited by beserkr on Sun 16. Jan 2022 23:28:15, edited 1 time in total.

Top
 Profile  
 
PostPosted: Sun 16. Jan 2022 23:03:02 
Offline

Joined: Wed 21. Dec 2016 15:13:38
Posts: 199
Location: Germany
Hi Mike,
That's really sad, I'm sorry -
Can you repair the damage ? I hope so !

It's a pity that no log file is available, which was actually the reason for the crash - it would also be nice if it were possible to log the separate values ​​for fades, framelosses and holds via Spirit or if they could be transmitted to the Spektrum remote control, for example , then you could log it using a TLM file and evaluate it later -
Since I could determine during my test that no reliable telemetry, mainly the resetting of the framelosses etc. could be recognized, the configuration with 2 satellites actually died for me -
In that case I will probably use an AR6610T and a 9747 for larger helis in the hope that I can see the two antennas or at least be able to determine the lower values ​​of the frame losses-
For smaller models up to 450 you can use a 4651T, where the display of frame losses and holds etc. also works reliably - the evaluation for both variants can then be carried out after the flight (TLM file saved in the radio).
When I get a chance, I will do another test with the AR6610T and 9747 configuration, testing it once with and once without ESC telemetry -
The test without ESC telemetry will go quickly, the test with ESC telemetry will take a while until I have my XLPower 520 ready... that's where the ESC telemetry will be tested -

Many greetings
Matthias


Top
 Profile  
 
PostPosted: Tue 18. Jan 2022 22:02:07 
Offline

Joined: Sun 28. Nov 2021 19:48:59
Posts: 35
Thanks Matthias!

Thankfully the damage wasn't too bad - I have not yet checked everything but it appears to be only blades, canopy, skids and tailfin. Maybe the feathering shaft. The soft mud certainly helped - the frames were full of it. I was lucky also because only ~10m away from the crash site was a river!

I have sent my DX9 to a service centre to be checked, to rule out any issue with the TX.

I'm unable to do any more testing at the moment. As soon as I have my TX back I'll try to do some basic testing on the ground to see if telemetry logs are still broken with 3.3.4. I will flash back to 3.3.3 to test this if necessary.

Interested to see your results of more testing....


Attachments:
PXL_20220115_131120309.jpg
PXL_20220115_131120309.jpg [ 6.86 MiB | Viewed 2549 times ]
Top
 Profile  
 
PostPosted: Wed 19. Jan 2022 5:41:27 
Offline

Joined: Mon 29. Jun 2020 6:03:45
Posts: 24
Ouch, that is painful to see.

Did you happen to look at your transmitter before you powered it off to see if any holds were reported?


Top
 Profile  
 
PostPosted: Wed 19. Jan 2022 8:20:36 
Offline

Joined: Sun 28. Nov 2021 19:48:59
Posts: 35
Yeah, it was a bad end to an otherwise great session!

Two holds and over 1000 frame losses. Flight lasted about five minutes.

The first hold recovered after a split second (I could hear the rotors start to spool down for a fraction, then recover), but then it immediately had another hold which caused the crash.

I've tried to keep an open mind as to the cause, but there's no single theory that stands out. If the TX is given a clean bill of health I'm not sure what I'll do. May have to save up for a Jeti DS-12...


Top
 Profile  
 
PostPosted: Wed 19. Jan 2022 20:03:21 
Offline

Joined: Wed 21. Dec 2016 15:13:38
Posts: 199
Location: Germany
Hello Mike,
interesting information - 1000 Framelosses are very high and then only two holds ?
Is the area known for radio interference ?
For a flight of 5 mins it is much to high ! What have you seen before with only the 4651T, was this significant better ?
I don't think that you can trust this information of framelosses , especially since the teltmetry is unstable with two satellites -
I have read various information on the internet, as an example if there is no signal for one second at any antenna, this results in 45 framelosses with a corresponding hold and an hold means failsafe - Framelosses are also consequence of flight time. It is seen as a connection quality. The longer the flight time, the higher the number of frame losses can be, with the same connection quality - Have you an friend with an OpenTx Radio maybe TX16S ? In the TX16S you can make a spectrum analysis on your flight location, here you can see maybe more significant Interference in the 2.4 GHz range, maybe this helps too for the cause research -

Many greetings
Matthias

Last edited 19.01.22, 8.12pm


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 126 posts ]  Go to page Previous  1 ... 8, 9, 10, 11, 12, 13  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
skymiles_red v1.0.1 designed by Team -Programming forum-سيارات للبيع .