It is currently Sat 12. Jun 2021 21:26:28

All times are UTC + 1 hour





Post new topic Reply to topic  [ 43 posts ]  Go to page Previous  1, 2, 3, 4, 5
  Print view Previous topic | Next topic 
Author Message
PostPosted: Fri 11. Jun 2021 13:30:30 
Offline
User avatar

Joined: Tue 17. Jul 2018 21:36:46
Posts: 52
Location: France - Normandy
Oh, I see !
I read too fast your 1st message. :roll:
Will check on my models this WE, but I do think the Spirit will not allow you a full travel on the tail servo in normal mode. It keeps some margin for itself.

Concerning your OTX programming, here are few comments:
- No need to specify "No Trim" everywhere. Disabling the trim in the FM0 (Flight Mode 0 = default one) will do the job.
If you are a "visual" guy, you can check my diagrams just here: FrSky Taranis - OpenTX data flow diagrams. It can very helpful to understand the data flow inside OpenTX. ;)
- I don't understand your CH05. Whatever is the SB switch position, the channel 05 will always send -25%.
- When a channel needs to be reverted, it is a good practice to use the "direction" parameter in the OUTPUTS/SERVOS menu. This is exactly the purpose of this parameter (revert channel direction). FYI, with an airplane model, the trim will work in the wrong direction if you are using a -100% ratio in the mixer!! :)

Concerning the LUA scripts, I guess your are using those ones ? → OpenTX Integration - 2 Installation
I don't have a clue why it is not working. :shock:
If you are using the FrSky integration cable it should work... All 3 wire are soldered? (the cable does include a transistor which need a power supply)
Is the cable plug in the right direction? (It is not "swappable", the shorter lead of the cable must be connected only to the RX).
By the way, if your are using the "inverted S.Port" instead the "S.Port" port, the integration cable is not required. A straight connection should do the job (I'm not 100% sure, I never tried myself). It is worth to try. :)

Seb


Top
 Profile  
 
PostPosted: Fri 11. Jun 2021 17:42:54 
Offline

Joined: Wed 09. Jun 2021 19:53:22
Posts: 4
>Will check on my models this WE, but I do think the Spirit will not allow you a full travel on the tail servo in normal mode. It keeps some margin for itself.
if i find motivation i will switch back to test this with jeti (currently 31c in my apartment, so no motivation to do anything :roll:), but i think it moved a lot more, but ofc i could also remember this wrong.

>- No need to specify "No Trim" everywhere. Disabling the trim in the FM0 (Flight Mode 0 = default one) will do the job.
i consider myself still a beginner with opentx so every tip is very welcome, ty.
when disabling trims in FM0 the other FM still shows the trim.
so i assume i must disable this in every FM that i use, or does FM0 supersede the others and it is jut a visual glitch?
Attachment:
FM.jpg
FM.jpg [ 277.88 KiB | Viewed 15 times ]


>If you are a "visual" guy, you can check my diagrams just here:...
i glanced over it, bookmarked it for later study's

>I don't understand your CH05. Whatever is the SB switch position, the channel 05 will always send -25%.
sorry forgot to mention i copied one of my other helis, this is normally gyro sensitivity.
there where different values in the beginning but, one value was perfect for that other heli and since this heli is not yet ready i havent changed that.
(i know there are other ways to get just one value, but sometimes you are lazy and it works....)

> When a channel needs to be reverted, it is a good practice to use the "direction" parameter in the OUTPUTS/SERVOS menu.
ty, changed that, now there also is an "INV" shown in the channel monitor for that channel ;)

>Concerning the LUA scripts, I guess your are using those ones ?
yes those are the ones, but i think the x-lite is just not supported currently
but i do not really need that, once a heli is setup is done and it flys well, i usually never touch the settings again.
while settings from the tx are nice, bringing a laptop to the field the first few flights is fine by me.

>If you are using the FrSky integration cable it should work... All 3 wire are soldered?
all 3 wires are soldered for frsky integration and sbus cable, telemetry works, see above for why i think it is not an hardware problem.

>By the way, if your are using the "inverted S.Port" instead the "S.Port" port, the integration cable is not required. A straight connection should do the job (I'm not 100% sure, I never tried myself). It is worth to try. :)
this RX has both normal and inverted s.port, since this goes to the sys port on the spirit, i think you will kill it without the integration cable.
the sysport is directly wired to the cpu and 5v is to much for that, at least ZeXx86 mentioned something like that on other threats here.


Top
 Profile  
 
PostPosted: Sat 12. Jun 2021 14:21:28 
Offline

Joined: Wed 09. Jun 2021 19:53:22
Posts: 4
reverted back to jeti and same behavior, tail travels only about 50% of the max when using the tx.
so i must have remembered wrong or mixed my memory with one of my other flight controllers where the tail travels all the way ;)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 43 posts ]  Go to page Previous  1, 2, 3, 4, 5

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
skymiles_red v1.0.1 designed by Team -Programming forum-سيارات للبيع .