It is currently Mon 04. Jul 2022 15:35:07

All times are UTC + 1 hour





Post new topic Reply to topic  [ 7 posts ] 
  Print view Previous topic | Next topic 
Author Message
PostPosted: Tue 24. May 2022 22:25:34 
Offline

Joined: Wed 11. Nov 2020 0:10:39
Posts: 27
I wanted to test the new crossfire support so started my unit, updated it to 3.4.0 and all was good. Then I set crossfire saved to the unit and when I power cycled it I can't connect anymore. It starts up with a blue led then when it initialized led goes out and I can't connect to it with Spirit settings anymore. I also tried recovery mode but then spirit settings only goes into "not responding" and doesn't seem to do anything. Any advice? The unit is a Spirit GT

Edit: tested two different interfaces and I now also tested to upgrade a Spirit II unit without setting it to crossfire and it boots up and works just fine after the updated and powercycle. Did I brick my Spirit GT somehow?

Edit2: if it matters I had my crossfire unit setup as futaba sbus and connected with 3wires when I rebooted it. So wiring was working and unchanged but once it booted I guess the Gt unit was setup for crossfire and my crossfire was still ppm/futaba.


Top
 Profile  
 
PostPosted: Wed 25. May 2022 7:14:50 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 11124
Hello,

don't worry, the unit will work well again.

I will send you special procedure to flash the firmware again.

1. Turn off the unit
2. Start the Spirit Settings in the Recovery mode, select correct COM port if there are more in the Connection - Devices.
3. Go to Update tab and press Left CTRL + Left Alt + H. You should sse "Bootloader Request"
4. Then you can press the Flash button and confirm it.
5. Connect Power Supply to the unit and flashing should start immediately.
6. Close the Spirit Settings

If not, please retry from step 1 again. It might take few retries because unit is not booting up properly.
All settings should be preserved and unit will operate normally.

We are very sorry for the inconvience. The problem should not appear again - we have made a small correction in the firmware - date 25.5.2022.
If you will be unable to fix it, we can do it for free.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Wed 25. May 2022 10:41:32 
Offline

Joined: Wed 11. Nov 2020 0:10:39
Posts: 27
I've tried this procedure 5 times now but I can't get it to flash. After I get the bootloader message and hit flash it goes one time quickly from 0-100% and then status is "Recovery mode.." and it stays at 0%. Anything else I should try? I will keep going for a few more times :)


Top
 Profile  
 
PostPosted: Wed 25. May 2022 10:44:31 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 11124
Please make sure that you are powering the unit when you can see 0% - Recovery mode. This is very important.
After any failed attempt it is needed to close the software, power off the unit and start again.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Wed 25. May 2022 10:53:37 
Offline

Joined: Wed 11. Nov 2020 0:10:39
Posts: 27
I got it now after 4-5 more attemps. Now it connects fine again :) Thank you for the quick support


Top
 Profile  
 
PostPosted: Wed 15. Jun 2022 1:50:46 
Offline

Joined: Fri 25. Jun 2021 4:21:41
Posts: 8
I am having the same issue with SpiritGT.

-Tried flashing firmware, sucess and waited for a bit. Unplug usb and power. Plug power and spirit flashes blue

-Tried recovery, same problem

-Tried bootloader recovery, when usb is plugged in and then I apply power when it says recovery 0% nothing happens. Spirit does not light up or anything.

-Tried both ways on 3 different computes (2mac 1PC)

-Always just blue flashing after power cycle.


Top
 Profile  
 
PostPosted: Wed 15. Jun 2022 7:23:59 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 11124
Hello, it seems this is very different issue than the original post. So I recommend to continue in a private message.
I will write you a message.

_________________
Spirit System developer


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
skymiles_red v1.0.1 designed by Team -Programming forum-سيارات للبيع .