It is currently Sat 02. Jul 2022 15:56:05

All times are UTC + 1 hour





Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
  Print view Previous topic | Next topic 
Author Message
PostPosted: Mon 24. Jan 2022 15:05:09 
Offline

Joined: Thu 13. Jan 2022 22:10:07
Posts: 12
Dear Spirit Experts,

Since I have to use CH 3 for throttle and CH 6 for Pitch in the T18SZ transmitter I am not able to use the spirit properly.
Diagnose shows all directions and channels correctly, but at controls the functions are exchanged on the RC control. For example: Mode 2 - left Pitch controls tilt function and vice versa the right stick controls now pitch.

I connected servos to the Spirit according manual K1- Pitch, K2- Tilt, K3- Roll, K4- Tail.

No idea how to solve the problem.

I appreciate your support!

Thanks and best regards,

Andreas


Top
 Profile  
 
PostPosted: Mon 24. Jan 2022 15:08:48 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 11115
Hello,

it is enough to use default channel mapping in both radio and Spirit unit.
Then all these functions will work out of the box without need of any change.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Mon 24. Jan 2022 16:44:04 
Offline

Joined: Thu 13. Jan 2022 22:10:07
Posts: 12
Sorry not working.

After reset of Spirit to factory settings and initiated New Heli Model in T18SZ, Pitch and Tilt function is still exchanged. I did no entries in the Spirit setup menu regarding the channels.

In DIAGNOSE everything indicates correct. Throttle channel is not used the menu because I didn't do any changes.

When I come to step 9/10 cyclic ring pitch authority I have to move the right stick at control to get max. positive/ negative pitch (what's wrong on my mode 2, should be left stick).

Even in step 7/10 sub trim adjustment: If I do, only the left servo (No. 1, Pitch servo) is moving. All three servos should move simultaneous to move the swashplate.

I use CCPM120 swashplate setting for Diabolo 700. The spirit is mounted left hand side, vertical 0.

Somehow/ somewhere I need to change the channels Pitch/ Tilt function.


Top
 Profile  
 
PostPosted: Mon 24. Jan 2022 16:53:28 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 11115
Hello,

if you can see that channels are moving correctly in the Diagnostic page in the Spirit software, then everything is OK.
Channel numbering is not relevant at all. They are different on both Futaba and Spirit, so please do not be confused.
Maybe only numbers are confusing you, but important is if everything is moving correctly in the Diagnostic tab.

Regarding next steps, the problems are probably caused by improper servo wiring. They are probably exchanged which can cause these problems.
In the Setup Wizard you should see which servo should be connected to which port.
Please note that it is dependent on selected swashplate type. With different swashplate there can be different wiring.

In Subtrim (tuning) only one servo should move normally. Pitch servo subtrim is not for collective pitch, but it is determining pitch servo itself.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Mon 24. Jan 2022 17:04:03 
Offline

Joined: Thu 13. Jan 2022 22:10:07
Posts: 12
Ok, then the pitch trim servo (No 1, left side) worked correctly in step 9/10.

I connected the servos exactly according the setup (please see above).
I tried to exchange the connections already a couple of times.
Will try again.
Maybe someone with the same transmitter can give me some hints?


Top
 Profile  
 
PostPosted: Mon 24. Jan 2022 17:13:15 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 11115
First please let me know if in Diagnostic page you can see that channels are moving correctly.

This mean Collective pitch is moving with Collective pitch bar.
Aileron stick is moving with Aileron bar.
Elevator stick is moving with Elevator bat.
Rudder ....

Is this correct?

If yes, then no more changes in your radio are needed.

If all this is OK please move with collective pitch stick up and down.
Swashplate servos should move up and down too.

If not, then you have to use next step in the Setup Wizard and reverse servos that are not moving in the right direction.

Please let me know at which step it is not working correctly.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Mon 24. Jan 2022 17:39:45 
Offline

Joined: Thu 13. Jan 2022 22:10:07
Posts: 12
That is all working correctly simultaneous to the sticks in the DIAGNOSE.
Until I reach step 9/10:

When I move now the left stick of the remote control the swashplate tilts forward down and backwards back (should be on the right stick)
When I move the right stick the swashplate moves up and down (should be on the left stick)

Even after DIAGNOSE shows everything correct, in step 9 the logic changes to opposite stick assignment.

I think that's a FUTABA thing. Somewhere I have to change a setting. I created again a H1 pure Helicopter model in the T18SZ.
It's not automatic easily working together.


Last edited by TRACON on Mon 24. Jan 2022 18:44:50, edited 2 times in total.

Top
 Profile  
 
PostPosted: Mon 24. Jan 2022 17:58:34 
Offline

Joined: Thu 13. Jan 2022 22:10:07
Posts: 12
Is there any experienced T18SZ user familiar with this behavior?


Top
 Profile  
 
PostPosted: Mon 24. Jan 2022 20:09:28 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 11115
Hello,

thank you for the message.

From your description it is clear that the problem is not related to radio at all.
It is only problem with Servo reversing and/or connection.

If you can see that channels are working correctly in diagnostic tab then everything in radio is OK and there is nothing you can do more there. So you can be perfectly sure that problem is only in the servos.

Please unplug swashplate servos and connect them again according diagram.
First connect CH2 - elevator servo.
Then connect CH1 and CH3. It is very important to connect them correctly, otherwise you will always get behavior you will see.

Then if you still see same behavior, then it is enough to reverse two servos in the Setup Wizard. And you will get correct behavior.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Mon 24. Jan 2022 20:56:35 
Offline

Joined: Thu 13. Jan 2022 22:10:07
Posts: 12
I am wondering that there is no sequence in connecting first CH 2 and then 1&3 in the setup wizard.
I have connected all the servos correctly according the menu first.
But I'll try this now...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
skymiles_red v1.0.1 designed by Team -Programming forum-سيارات للبيع .