Spirit System

[SOLVED] Nothing takes any effect !?
Page 1 of 1

Author:  maddi67 [ Mon 22. Feb 2021 13:29:01 ]
Post subject:  [SOLVED] Nothing takes any effect !?



today i went out to make first tests with my T-Rex 550 with Spirit RS and Geolink.
Before and after this, i´ve controlled all switch effects / funktions with the Spirit Software.
All channels and functions run as programmed respectively indicators show coorect switching.

These functions are:

- Altitude Limit
- Position and altitude hold
- Return to home

First i make a few circles in order to warm up after winter...everithing ok.

Sure, the blue light at the geolink burns steady and as i told all functiuns and switches have been tested multiple times
wit the Spirit Software.

Than i decide to activate altitude Limit - set to 5 m abover ground . I simply stop steering at about 10m in a nearly horizontal Position and let the heli slowly fall by himself...nothing happens.
If i did´nt intervene i believe the Heli would touch ground.

Where is the mistake ?

Second i decide to test position and altitude Hold which ar combined at one switch.
Once again i lift the heli about 15 m and stop steering i in a nearly horizontal position, then i activated position and altitude hold. Nothing happens, the heli drifts away with the wind and climbs or descends,
no effect visible. I tested it several times and let him go more and more to see that anything happens. But nothing happens...

Where is the mistake ?

Because of this i didn´t test Return to home.

But i ask myself why nothing happens respectively why does nothing takes a visible effect ?

Do i have to activate a stabilizatiom mode in order to make it work ?

Author:  ZeXx86 [ Mon 22. Feb 2021 14:23:14 ]
Post subject:  Re: Nothing takes any effect !?


when you engage Altitude Limit at the ground, swashplate must go up as with Rescue engaged.
Is this the case?

If no, then I am afraid there will be some mistake in programming. Maybe you are using more Banks.

I highly recommend to do the testing in a higher altitude for the first time. So you can set Altitude Limit to engage at 10 - 15 meters for example.

Am I right you can see Active label in the GeoLink window or in the Diagnostic tab?

Author:  maddi67 [ Mon 22. Feb 2021 15:16:38 ]
Post subject:  Re: Nothing takes any effect !?


yes, as you describe, when i engage Altitude Limit at ground swashplate immediate rises up / increases pitch.

In order to minimize complications, i do not switch banks at his time, all test were made with bank zero. (No switch targets to channel 7 in transmitter and it is in neutral position)

You´re right, i can see Active label in Geolink Window and Diagnostic Tab. There engagement of functions is shown correct.

Author:  maddi67 [ Wed 24. Feb 2021 14:57:24 ]
Post subject:  Re: Nothing takes any effect !?

I´ve calibrated the compass now and suddenly everything works fine.
According manual of geolink you might calibrate, my opinion is you must calibrate the compass.
However, everything works fine now.

Author:  ZeXx86 [ Wed 24. Feb 2021 16:53:54 ]
Post subject:  Re: Nothing takes any effect !?

That is great news.
It is not needed, because all GeoLink modules are coming precalibrated.
But such calibration is not good for other countries for this reason it is really highly recommended.

If one will press at the Compass Calibration then GeoLink will switch to the calibration mode.
If one will try to fly with it, no GeoLink feature will work.

So it must be finished if compass calibration was requested.

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB® Forum Software © phpBB Group