It is currently Thu 06. May 2021 7:54:47

All times are UTC + 1 hour

Post new topic Reply to topic  [ 1 post ] 
  Print view Previous topic | Next topic 
Author Message
PostPosted: Mon 02. Nov 2020 2:06:10 

Joined: Mon 02. Nov 2020 1:44:51
Posts: 1
I just moved my Spirit II from a Trex 450Pro V2 3GX with stock ESC/BEC, to a SAB Fireball 280 w/ Hobbywing V4 60A ESC; but after the move I am having trouble getting the Spektrum satellites to work. Prior to the move, it was working and has been updated to firmware 3.2 some weeks ago with many flights already.

The power source had always been the ESC/BEC into Aux1 before the move and through the move process. However, I did experiment with one of my flight packs (7.4V) into RUD when troubleshooting when it wasn't working.

There were several problems:
- I could not get the Spektrum satellites to bind. I am able to put them into bind mode with the Spirit II, but when the transmitter is also put into Bind, it says "Binding", then "Transmitting" and does not successfully bind after that. The Rx LED would turn off, and the Tx would return to the normal operational screen. I solved this problem by binding the Rx attaching it to the Spektrum AR8000 Rx. The satellite is now bound, and I have even tested it on another heli and it works.
The weird thing is that I did get it to bind when I first installed the Spirit II a few months ago just by following the instructions in the manual.

- The more important problem now is that there is no stick input under the Diagnostics tab. The satellite is connected with connection LED lit, and the Spirit II is connected to my computer via USB. The stick input diagnostics is completely unresponsive. I have tried with four different receiver modules; 2 different Spektrum modules, and 2 HK Spektrum compatible modules, and all have the same outcome.

- I had also received some "Unstable Connection" errors on the PC application, and asking me to Reconnect. Sometimes it is able to reconnect, and sometimes it cannot. I have inspected all cables, and everything appears to be fine.

Other things I have tried:
- Updating firmware again to 3.2
- Factory Reset
- Change receiver to something other than Spektrum DSM, then changing back to Spektrum
- Reset model in Tx.
- Re-bind Rx multiple times (Bind plug in AIL/PIT/ELE)
- Tried different power source (two different BEC/ESC), 7.4V Lipo flight pack
- No other devices connected except power source and USB cable (SYS)
- All the satellites confirmed working and with stick inputs working on other models (Without changing the binding)
- Also stick movement is confirmed in the monitor of the Spektrum Tx
- Tried connecting the satellite to SAT2 (nothing else connected to the other port)

Has anybody had this issue or would be able to help?

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC + 1 hour

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
skymiles_red v1.0.1 designed by Team -Programming forum-سيارات للبيع .