It is currently Tue 11. May 2021 21:45:00

All times are UTC + 1 hour

Post new topic Reply to topic  [ 1 post ] 
  Print view Previous topic | Next topic 
Author Message
PostPosted: Fri 31. Jan 2020 18:03:58 

Joined: Tue 02. Oct 2018 22:30:13
Posts: 8
Life has kept me away from my helis since last summer so today I downloaded Spirit Settings 2.7.1 and now I'm unable to connect/update the unit's FW. Apparently when I downloaded/installed 2.7.1 it replaced/erased the previous version (2.6.?) so I can't revert to the earlier version. 2.7.1 will open w/o my Spirit connected in demo mode but when the unit is connected Spirit Settings won't open/connect at all. It says "scanning for devices" and eventually shows "program not responding". This happens on both of my Spirits but they are responding to my TX, just won't connect to my computer. I'm kinda stumped as this is a newer computer (worked on v2.6 last summer) and FWIW I've tried two different Spirit USB cables, one which I got with my second Spirit and has never been used until today so I can rule out a faulty cable. Also the FrSky integration does work so it's not a problem with the SYS port on the units. I've also tried deleting Spirit Settings and redownloading 2.7.1 several times, nada. AFAIK it has to be able to connect to use restore or recover mode. Just wanted to recalibrate my compass after moving to a different state..... Any ideas?

EDIT: Apparently the drivers are not installing (yes I tick the install drivers box). The manual states "To make sure your USB interface will work properly, please right click at the Computer and open Device Manager. There you can open COMs & LPTs section which must contain Silicon Labs CP210x device. Device name must contain assigned COM port.". Nothing shows up there and I even went to Silicone Labs website to download the driver. It's saying the driver downloads and is working but.....nothing in device manager. My computer is only 8 months old so apparently this is more of a computer issue than a software issue? Oh well, it worked last summer.....

EDIT#2: Mikej on HF advised me to disable the Bluetooth on my computer and it works now! Wow, never thought about Bluetooth being an issue since I'm not even using a BT module works now!


Blade 230S-Rakon Kit/Fusion 270-Spirit-Geolink/T-Rex 470LT-Spirit-GeoLink/Taranis X9E w/Spektrum Module

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC + 1 hour

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
skymiles_red v1.0.1 designed by Team -Programming forum-سيارات للبيع .