It is currently Fri 07. May 2021 13:30:40

All times are UTC + 1 hour





Post new topic Reply to topic  [ 22 posts ]  Go to page 1, 2, 3  Next
  Print view Previous topic | Next topic 
Author Message
PostPosted: Thu 19. Sep 2019 21:39:51 
Offline

Joined: Thu 29. Dec 2016 22:33:30
Posts: 3
Hello Tomas or anyone:-)
Having a difficult time getting position hold to work.
Using Spirit Pro with Geolink and 2 spectrum DSMX satellite receivers.
It will hold a relative decent position after take off but begin to drift soon after. I can hold additional aileron to maintain position but within a minute or so it will take full aileron to continue to hold position. So I must land. Upon landing swash does not go to level but maintains a lot of aileron typically right aileron.
Don't know how to fix this problem.
Also if I fly left or right or forward and release sticks gently to neutral then heli over corrects a lot in opposite direction I was moving heli.
Ie. Fly forward gently, release stick then rapid backward flight.
Finally if I hold position with stick input the system makes large step changes. Not always but typically jerky corrections.
I've tried different settings without luck.
So in my mind the control loop is too slow and corrections are to large.
To me this means P is too large and I is too small. That is if we are using P and I as described in a PID control loop.
P=Gain and I=Integral and D=derivative

Many years ago I used a DJI Wookong H system which I was able to set up and had wonderful performance.
Yes $1200 but also no longer available.
I am hoping with your help I can get to stable position hold for flying scale helicopters... graceful gentle change of direction.
I'm flying a Trex 550x on 6s at 75% throttle for low head speed and pitch restricted to , I believe 9 degrees.
Many thanks,
Larry

Update: Still playing with gains. Working a little better.
Added altitude hold on a different switch first flight went well.
Crashed on second flight when I turned off altitude hold. Heli descended fast to the ground in a vertical path as position hold was still active. Broke skids and tail blades.
Am wondering if collective stick position is important when altitude hold is turned off. Mine should have been in a hover position but cant say for sure. This could be a big issue if you are not aware of it. Thoughts???


Top
 Profile  
 
PostPosted: Fri 04. Oct 2019 16:21:14 
Offline

Joined: Fri 04. Oct 2019 16:13:04
Posts: 3
Hi, I have the same problem, unfortunately I can't fix it, do you have any new knowledge?


Top
 Profile  
 
PostPosted: Sun 06. Oct 2019 20:53:17 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 10379
Hello,

if drifting start to occur then unfortunately this is caused very likely by very excess vibrations.
This would induce drifting also without GeoLink with Coaxial or Stabilisation mode only.

To confirm this, you can turn off all GeoLink features and enable only a Stabilisation mode.

This is nothing you could set in the software as the problem should not occur in a normal circumstances.

It should just hold position at any moment whenever you will start it. If not, then also other modes will likely be failing (even Rescue mode) as it is all related to the same issue.

Could you please measure vibration level - especially for Y axis?

When you will turn off any GeoLink feature it will return to the normal flight mode. So the collective pitch will work normally too which mean if it is under hovering position it will always descend. If it is above it will ascend. So the feature itself is not dependent on the collective pitch but normal flight mode is. So the model will do how the stick is set.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Mon 17. Aug 2020 3:10:00 
Offline

Joined: Sat 15. Aug 2020 15:27:09
Posts: 17
I am having the same type issues with Position Hold. Any resolutions ?? Two new units that are a month old.
Seems like the more I try to push a stick to keep it from drifting off, the more I need to continue to push the stick.
When I flip back to normal out of Position Hold... she takes off hard. It is hard to catch it to keep it from crashing.


Top
 Profile  
 
PostPosted: Mon 17. Aug 2020 7:17:55 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 10379
Hello,

1. Was GeoLink Compass calibrated?
2. Is Coaxial mode itself working properly? (no GeoLink feature enabled) - this mean to hover stable.
3. How the GeoLink is mounted at the model? Can you share a photo?

All this three points can cause that Position Hold (and other modes) might not work properly.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Mon 17. Aug 2020 21:59:32 
Offline

Joined: Sat 15. Aug 2020 15:27:09
Posts: 17
1. Yes I did a calibration after the first strange flight.
2. I do not have Coaxial set to be on all the time, It engages with Position Hold.... right ?
* How do I set Coaxial to be on all the time??? *Do I Just flip the stabilization switch before take off ?? I do have Coaxial set in the program.
*Can I take off with Coaxial engaged ???
3. Pictures enclosed. The unit is mounted with your plastic mounting device and three small tie wraps through the holes in it and of course your sticky tape to hold it down.
there doesn't seem to be much vibration.

I have a Trex 550 with a three blade head and a three blade tail.
I take off in normal mode, seems to fly ok, but no stabilization at all. Then I engage Position Hold only. (Coaxial is set in stabilization as well) When I do the Heli begins to move slowly backwards. I push forward stick but have to keep pushing forward more and more to keep it from flying back.
Seems like the more I try to push a stick to keep it from drifting off, the more I need to continue to push the stick.
When I flip back to normal out of Position Hold... she takes off hard forward. (because of my fault of keeping the stick forward due to above) It is hard to catch it to keep it from crashing. Not sure what I am doing wrong. I have successfully set up Two Skookum's SK720's with GPS in the past.
Need help.

What is happening is very much like another user's report below.

Having a difficult time getting position hold to work.
Using Spirit Pro with Geolink and 2 spectrum DSMX satellite receivers.
after take off begin to drift soon after. I can hold additional aileron to maintain position but within a minute or so it will take full aileron to continue to hold position.
I am hoping with your help I can get to stable position hold for flying scale helicopters... graceful gentle change of direction.
I'm flying a Trex 550x on 6s at 75% throttle for low head speed and pitch restricted to


Attachments:
20200817_153838.jpg
20200817_153838.jpg [ 1.22 MiB | Viewed 330 times ]
20200817_153831.jpg
20200817_153831.jpg [ 1.23 MiB | Viewed 330 times ]
20200817_153755.jpg
20200817_153755.jpg [ 832.4 KiB | Viewed 330 times ]
Top
 Profile  
 
PostPosted: Tue 18. Aug 2020 7:15:42 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 10379
Hello,

it looks good, thank you!

You can verify if Coaxial mode is working properly just by not engaging Position Hold, just Coaxial (Stabi mode).
I recommend first to turn off all GeoLink features. Then try the basic features of the unit first, because Position Hold required to work Coaxial mode to work properly.

You can engage Coaxial mode with Negative gyro gain by default. But if F: Stabi mode is assigned, then you can engage it with assigned channel.
It is enough to set Stabi/Function to Coaxial.

You can take off with Coaxial mode and fly with it all the time if really needed.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Wed 19. Aug 2020 22:14:20 
Offline

Joined: Sat 15. Aug 2020 15:27:09
Posts: 17
Thank you for sticking with me on this.
OK, I removed all the check marks on the Geo-link page.
Then set up the Stabilization mode on a switch, set to Coaxial.
I checked the compass calibration that I had done.
With my laptop Heli sitting outside it showed 90 Deg. when pointed north.
Checked everything again, and flew it.
I lifted off in Coaxial Stabilization mode.
It seemed fine for a few minuets, Coaxial Stabilization was working, It did try to self correct.
but then after flying for several minuets,
it seemed to continually take more and more stick to keep it from drifting in the slight 5mph wind.
At the end, I had full right stick in it to keep it stationary.
I finally felt I soon I was not going to be able to hold it from drifting away and landed it where I could.
Did not want to take Stabilization off in flight due to a previous disaster described above in Position Hold.
Basically it acted like what it did in position hold... only it respond (at first) and drifted more in flight.
Please help with this situation.


Top
 Profile  
 
PostPosted: Thu 20. Aug 2020 7:19:51 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 10379
Hello,

thank you for the details!

Now we know why Position Hold mode can't work. So the issue is not related to GeoLink module actually.

Do you have a fan installed on the model? Especially if it is HobbyWing fan, could you try to disconnect it and repeat the test?

If this will not help, could you enable Stabi Correction in the Advanced/Expert settings and repeat the test?

Please always try in a high altitude.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Fri 21. Aug 2020 1:34:27 
Offline

Joined: Sat 15. Aug 2020 15:27:09
Posts: 17
Please tell me what Stabi Correction does in the advanced settings. What will it change or affect ??


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 22 posts ]  Go to page 1, 2, 3  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
skymiles_red v1.0.1 designed by Team -Programming forum-سيارات للبيع .