It is currently Mon 16. Dec 2019 10:58:34

All times are UTC + 1 hour





Post new topic Reply to topic  [ 10 posts ] 
  Print view Previous topic | Next topic 
Author Message
PostPosted: Fri 29. Nov 2019 19:05:20 
Offline

Joined: Thu 25. Oct 2018 12:05:29
Posts: 28
Hello,

I am trying to to activate internal governor of Spirit Pro and therefore I configured my YGE 90 LV with progcard III like descripted for use with external governor.
The RPM signal from slave cable is connected to PIT, Spirit is configured too (divider, Ratio, governor and so on), but motor speed is not stabilized by Spirit.
The tester in Setup menu says alternately signal active and signal inactive, but RPM is not controlled anyway.

What can I do?

Toni


Top
 Profile  
 
PostPosted: Sun 01. Dec 2019 15:28:57 
Offline

Joined: Thu 25. Oct 2018 12:05:29
Posts: 28
Hello,

some more details:
- Spirit log file shows "Governor engaged", but Motor spools up to about 3400 +- 150 RPM, even though max. Speed stored in Spirit is 3200 and given throttle value is 60% (result should be 1920 RPM).
- Telemetry data show a constant "Gov"-value (e.g. 1470) for ESC which should actually change to stabilize the motor.

Hoping for some ideas,
Toni


Top
 Profile  
 
PostPosted: Wed 04. Dec 2019 10:32:05 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 9071
Hello,

are you trying with or without blades?

Was your ESC throttle range calibrated with Spirit?

Can you see a RPM in the Spirit Settings when motor is spinning?

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Thu 05. Dec 2019 8:42:39 
Offline

Joined: Thu 25. Oct 2018 12:05:29
Posts: 28
Hello,

I tried with and without blades, result the same.
Throttle range was calibrated with spirit and I can see RPM in the settings.

Regards,
Toni


Top
 Profile  
 
PostPosted: Mon 09. Dec 2019 9:08:55 
Offline

Joined: Thu 25. Oct 2018 12:05:29
Posts: 28
Hello,

some additional data to my problem:
Throttle range in transmitter (FrSky Horus X12s) is set from 1099 us to 1945 us, so that Spirit settings show exactly -100 to +100 %. Same values can be read out on AUX1 of Spirit pro (using RCE-MT9 / Align) and are set so in Spirit settings too.
RPM signal shows a nearly perfect square wave signal without any noise on oscilloscope.

Attached is a little part of a logfile showing GOV- and RPM-values. Conditions: heli standing on the floor without blades, switching between three throttle straights.
GOV 1449 is the value for 60 % which should be about 1920 RPM, GOV 1499 for 70 % (2240 RPM) and GOV 1548 is for 80 % (2560 RPM). Max. RPM in Spirit settings is 3200.
As you can see the GOV-values don’t vary in each region but RPM do – for more than 100 and they are much too high.

YGE 90 LV settings are controlled together with YGE support and found to be correct. There one considers it a mistake of Spirit.

Regards,
Toni


Attachments:
File comment: log file with GOV and RPM values
5.12.19.xlsx [11.95 KiB]
Downloaded 4 times
Top
 Profile  
 
PostPosted: Mon 09. Dec 2019 21:06:08 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 9071
Hello,

thank you for the detils.
Values you are reading as GOV are not in RPM. These are in micro seconds.

Please take a look at the Governor window for Requested RPM in the Spirit Settings. There Current and Requested RPM should be approximately same.
But it is important to add main blades, because without main blades load is very small and governor might not work properly. But I think it will work well.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Tue 10. Dec 2019 9:00:13 
Offline

Joined: Thu 25. Oct 2018 12:05:29
Posts: 28
Hello Tomáš,

I know that GOV is in microseconds and I will do another try with blades, but I am not very hopeful because I did it before without any success.
In my opinion GOV value has to vary to keep RPM constant, but all my logs show the opposite.

Regards,
Toni


Top
 Profile  
 
PostPosted: Tue 10. Dec 2019 16:19:11 
Offline

Joined: Thu 12. May 2016 0:20:26
Posts: 74
Hi,
I also attempted to use Spirit governor with a gas engine helicopter. I got the same result you are experiencing where the RPM would not regulate and run too fast. I verified good RPM signal to Spirit but it never worked correctly. I ended up using a Futaba governor on my gas helicopter that works good. On my 700 electric helicopter I just used the governor in the Hobbywing V4 ESC. That governor works very good.


Top
 Profile  
 
PostPosted: Wed 11. Dec 2019 15:46:51 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 9071
George Baker: From description of the pilot it is very different problem.

If I understand it correctly you are assuming the Governor is not working, because values are not changing. Am I right?
If there is no load, then governor is not doing basically any changes.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Thu 12. Dec 2019 18:26:08 
Offline

Joined: Thu 25. Oct 2018 12:05:29
Posts: 28
Hello Tomáš,

yes, you are right.
Here are my results after a new test with main blades mounted and standing on the ground connected to Spirit Settings to see requested and current RPM.
Spooling up to requested 1920 RPM (60% of max. RPM) the settings window shows me about 2500 RPM +-100 - governor not working.
Switching to requested 2240 RPM (70% of max. RPM) then seems to activate governor and I get a reading of 2240 +-25 RPM.
Switching back to 1920 now gives me 1920 +-25 RPM - governor seems to continue working.
After stopping the motor and new start to 1920 same behaviour as before - governor not working. Load seems to be not enough.
Giving some more negative or positive pitch to increase the load helps nothing.

Regards,
Toni


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
skymiles_red v1.0.1 designed by Team -Programming forum-سيارات للبيع .